White page with update 1.6>>>2.0.1 & 2.0.2

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
J@r0d
Posts: 6
Joined: Fri Jul 06, 2007 9:54 am

White page with update 1.6>>>2.0.1 & 2.0.2

Post by J@r0d » Fri Jul 06, 2007 10:30 am

I have a dedicated serveur with debian etch

I install only 2.0.1>>>> It's ok and i have not probleme

I update 1.6 to 2.0.1>>>> execute update.php it's ok, but when a updating is ok the whitepage screen in public mode and in admin mode


I'm activate debug:

Code: Select all

Fatal error: Call to a member function fetch_object() on a non-object in /var/www/chi/phpmyfaq-2.0.1/inc/PMF_DB/Mysqli.php on line 124


Sorry for my english ;)
Last edited by J@r0d on Mon Jul 09, 2007 9:33 am, edited 1 time in total.

matteo
Posts: 572
Joined: Sun Nov 20, 2005 6:53 pm
Location: Italy

Post by matteo » Fri Jul 06, 2007 11:36 am

Hi,
did you launch the update stage (http://hostname/anydir/install/update.php) after updating the files?

Ciao,
Matteo
phpMyFAQ QA / Developer
Amazon.co.uk Wishlist

J@r0d
Posts: 6
Joined: Fri Jul 06, 2007 9:54 am

Post by J@r0d » Fri Jul 06, 2007 1:21 pm

matteo wrote:Hi,
did you launch the update stage (http://hostname/anydir/install/update.php) after updating the files?

Ciao,
Matteo
Yes, i launch only one this link:

Code: Select all

http://toto.com/phpmyfaq/install/update.php

J@r0d
Posts: 6
Joined: Fri Jul 06, 2007 9:54 am

Post by J@r0d » Mon Jul 09, 2007 9:34 am

I update 1.6 to 2.0.2 and this result is whitepage, i activate debug

Code: Select all

Fatal error: Call to a member function fetch_object() on a non-object in /var/www/chi/phpmyfaq-2.0.2/inc/PMF_DB/Mysqli.php on line 124

Thorsten
Posts: 15182
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Mon Jul 09, 2007 10:52 am

Hi,

did you enabled MySQLi support in PHP?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

onimalu
Posts: 6
Joined: Tue Aug 30, 2005 10:04 am

same trouble white page

Post by onimalu » Mon Jul 09, 2007 6:45 pm

I have a same problem when upgrading from 1.6.11 -> 2.0.2
white page and log:

PHP Fatal error: Call to a member function fetch_object() on a non-object in /some_path/inc/PMF_DB/Mysqli.php on line 124

MysqlI Support enabled on PHP

J@r0d
Posts: 6
Joined: Fri Jul 06, 2007 9:54 am

Post by J@r0d » Mon Jul 09, 2007 8:12 pm

Thorsten wrote:Hi,

did you enabled MySQLi support in PHP?
Yes

Thorsten
Posts: 15182
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Mon Jul 09, 2007 8:15 pm

Hi,

did you both enabled the debug mode?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply