2.0.4 scrolls to bottom of page

In this board you can talk about general questions about phpMyFAQ

Moderator: Thorsten

Post Reply
jazcyk
Posts: 385
Joined: Wed Sep 07, 2005 1:32 pm

2.0.4 scrolls to bottom of page

Post by jazcyk » Sun Dec 02, 2007 2:34 pm

After upgrade to 2.0.4 (from 2.0.2) I experience that when a page belonging to PMF is opened, the browser scrolls to bottom of page. I do not think it did before (neither 1.6.x nor 2.0.2).

And I would prefer to read from the top ... :-)

Thorsten
Posts: 15051
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Sun Dec 02, 2007 4:02 pm

Hi,

I cannot reproduce this even on your page... which browser do you use?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

jazcyk
Posts: 385
Joined: Wed Sep 07, 2005 1:32 pm

everyone!

Post by jazcyk » Sun Dec 02, 2007 4:53 pm

I can reproduce this with IE, FF and Opera.

But if the post is very large if will only scroll halfway or less!


This
http://webyog.com/faq/content/33/7/en/s ... story.html
displays from


IE:
be) at the 'parent'.
Horizontal scrollbars were added where missing.
Fixed a display issue in DATA tab with large DPI monitor setting.


SQLyog 6.13 (November 2007)

Bug Fixes

Opera:
Sqlyog could crash when trying to connect to a server when the thread used for establishing the previous connection had not stopped executing (connection code wasn't thread-safe).
Structure Sync could generate DROP statements where the name of the object to be dropped was empty.
It will vary a line or so depending on whether browser is maximized on not!


Maybe it is a Vista issue?

Thorsten
Posts: 15051
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Post by Thorsten » Mon Dec 03, 2007 7:55 am

Hi,

works okay on Windows XP. I do not have any PC with Vista...

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Lidio
Posts: 25
Joined: Mon Dec 10, 2007 9:26 pm

Post by Lidio » Mon Dec 10, 2007 9:54 pm

Hi jazcyk,

it is not a Vista issue, same thing with Windows XP. I have just been "playing" with phpMyFAQ 2.0.4 (great product!) and discovered the same issue. My analysis is not complete but I believe is it related with the the Javascript

Code: Select all

<body dir="ltr" onload="javascript:focusOnSearchField();">
which makes the search field visible.

The effect is very pronounced for me due to a large number of categories and subcategories and selecting an item from the subcategories. (Sorry Thorsten my site is not yet accessible on the internet, internal use for now.) Jazcyk I see in your FAQ it just scrolls a few lines.

One work around is to modify template/index.tpl and move

Code: Select all

                <!-- start search box -->
                <div class="content">
                    <div id="search">
                    <form action="{writeSendAdress}" method="get">
                    <label for="suchbegriff">{searchBox}</label>
                    <input alt="search..." class="inputfield" type="text" name="search" id="suchbegriff" size="18" /><br />
                    <input type="submit" name="submit" value="Go" class="submit" />
                    <input type="hidden" name="action" value="search" />
                    </form>
                    </div>
                </div>
                <!-- end search box -->
to top of right column. Not sure of any adverse effects.

Another solution is to adopt a layout similar to http://faqs.pcbsd.org/ (note this site is not always accessible, at least from my ISP). Good luck,

Lidio.

Post Reply