phpMyFAQ 2.7.9 - WYSIWYG does not show

Please report bugs here!

Moderator: Thorsten

Post Reply
j-prause
Posts: 17
Joined: Mon Apr 29, 2013 9:29 pm
Location: Czech Republic

phpMyFAQ 2.7.9 - WYSIWYG does not show

Post by j-prause » Mon Apr 29, 2013 9:47 pm

When editing FAQ or News - the WYSIWYG shows correctly if language is set to English.
When I switch to language Czech - the WYSIWYG does not show, just plain frame with the answer content.
The same pays for news.
Thanks.
Josef

Thorsten
Posts: 14793
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: phpMyFAQ 2.7.9 - WYSIWYG does not show

Post by Thorsten » Tue Apr 30, 2013 9:48 am

Hi,

do you see any JS errors?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

j-prause
Posts: 17
Joined: Mon Apr 29, 2013 9:29 pm
Location: Czech Republic

Re: phpMyFAQ 2.7.9 - WYSIWYG does not show

Post by j-prause » Tue Apr 30, 2013 10:46 am

Hi Thorsten,
no, I can't see any error. Where should I see it?
Did you try to reproduce this situation?
Josef

Thorsten
Posts: 14793
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: phpMyFAQ 2.7.9 - WYSIWYG does not show

Post by Thorsten » Tue Apr 30, 2013 2:02 pm

Hi,

you should see the errors in your browser. Hadn't time to reproduce this issue yet.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

j-prause
Posts: 17
Joined: Mon Apr 29, 2013 9:29 pm
Location: Czech Republic

Re: phpMyFAQ 2.7.9 - WYSIWYG does not show

Post by j-prause » Tue Apr 30, 2013 2:19 pm

Hi,
as I said before, browser (Firefox, Chromium, Opera) shows no error.
Josef

j-prause
Posts: 17
Joined: Mon Apr 29, 2013 9:29 pm
Location: Czech Republic

Re: phpMyFAQ 2.7.9 - WYSIWYG does not show

Post by j-prause » Wed May 01, 2013 9:25 am

Hi Thorsten,
let me submit my research of the issue with WYSIWYG:
In phpMyFAQ directory /admin/editor/langs there are 3 files: cs.js, de.js, en.js
The cs.js is one-line file whereas de.js and en.js are "normal" text files line by line.
See attached screenshots.
pmf-cs-js.png
pmf-de-js.png
pmf-en-js.png
Now, if I delete the file cs.js editing works OK with WYSIWYG available.
NOTE: the same issue occurs in phpMyFAQ 2.8.0-RC4.
Bye,
Josef
You do not have the required permissions to view the files attached to this post.

Thorsten
Posts: 14793
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: phpMyFAQ 2.7.9 - WYSIWYG does not show

Post by Thorsten » Wed May 01, 2013 8:42 pm

Hi,

thanks for the hint, cz.js is removed for 2.8.0, and an unlikely 2.7.10 release.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply