Glossary term in FAQ title causes jumping text

Please report bugs here!

Moderator: Thorsten

Post Reply
dajoker
Posts: 59
Joined: Sat Jan 30, 2010 1:01 am

Glossary term in FAQ title causes jumping text

Post by dajoker » Thu Jul 25, 2013 5:23 pm

I haven't looked at this (the code) closely yet, but I'm not strong with the CSS force so I'm skeptical that I can fix it.

Basically the symptom shows up when a glossary term shows up in a FAQ title when viewing the entire FAQ via the regular web interface (vs. seeing the title in a list of results, or via RSS, or something else). Because the styling around the glossary term causes a nice little popup with the term's definition to appear, it causes the text to move out of the way and generally it is not appealing overall.

Suggestions for improvements, in order of preference:
1. Do not make glossary terms special in FAQ titles. It is likely that the term will appear later in the actual FAQ, and if not, well, check the glossary.
2. Make the glossary, while in the title, have a simpler tooltip kind of functionality so that the title text itself is not jumping around.

I can duplicate this pretty easily and send screenshots if it helps, but basically put a FAQ title word into the glossary and then view the FAQ and mouseover the glossary term.

Fixes appreciate.... not critical, and I'll implement #1 when I have time, but I imagine this is something that others would want, so posting here so that it's documented somewhere in case I get hit by a bus or something. :-)

-dajoker

Thorsten
Posts: 15091
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Glossary term in FAQ title causes jumping text

Post by Thorsten » Thu Jul 25, 2013 6:45 pm

Hi,

I'll check it and try to improve it.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

cdsaenz
Posts: 3
Joined: Sat Sep 14, 2013 2:59 pm

Re: Glossary term in FAQ title causes jumping text

Post by cdsaenz » Sun Sep 15, 2013 11:13 pm

Same issue here. For now what I did (as dajoker said it's ok for me to have titles without glossary reference and CSS may be harder to explore) is to edit artikel.php:

At around line 65:

Code: Select all

// Add Glossary entries
//original:  $question = $oGlossary->insertItemsIntoContent($faq->getRecordTitle($recordId));
$question = $faq->getRecordTitle($recordId);  // new line
This is working fine for me. Thanks!

Thorsten
Posts: 15091
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Glossary term in FAQ title causes jumping text

Post by Thorsten » Mon Jan 06, 2014 8:51 am

Hi,

this will be improved in 2.8.6, we removed the glossary replacement in the FAQ questions.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply