Search bug or feature

Please report bugs here!

Moderator: Thorsten

Post Reply
McGregor
Posts: 11
Joined: Thu May 19, 2016 3:59 pm

Search bug or feature

Post by McGregor » Fri Jun 03, 2016 1:02 pm

In new 2.9.0 search has one bug or feature?

Problem is when you enter first search word it finds FAQs OK
but when you click and examine one FAQ
and try to search for another FAQ,
it searches only in category of last opened FAQ. Is this feature?

Of course if you go to Main page search works again normally.

regards
Gregor

Thorsten
Posts: 14792
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Search bug or feature

Post by Thorsten » Fri Jun 03, 2016 8:04 pm

Hi,

cannot reproduce this, do you use normal search or Elastticsearch?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

McGregor
Posts: 11
Joined: Thu May 19, 2016 3:59 pm

Re: Search bug or feature

Post by McGregor » Mon Jun 06, 2016 7:35 am

We use normal search. Elasticsearch doesn't work. (I posted that in another topic)

Below some pictures:

First search for word "TEST" from main page:
Image
Image

Second search same word "TEST" from some opened FAQ:
Image
Image

Thorsten
Posts: 14792
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Search bug or feature

Post by Thorsten » Tue Jun 07, 2016 7:48 pm

Hi,

ah, okay. Will check it.

If you have an Elasticsearch instance running, it should work.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Thorsten
Posts: 14792
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Search bug or feature

Post by Thorsten » Tue Jun 07, 2016 7:50 pm

Hi,

here's your ticket: https://github.com/thorsten/phpMyFAQ/issues/1162

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

McGregor
Posts: 11
Joined: Thu May 19, 2016 3:59 pm

Re: Search bug or feature

Post by McGregor » Wed Jun 08, 2016 2:06 pm

Cool.
thanks

regards
Gregor

Thorsten
Posts: 14792
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Search bug or feature

Post by Thorsten » Thu Jun 23, 2016 8:47 pm

Hi,

this is the fix: https://github.com/thorsten/phpMyFAQ/co ... cee9f54c52

Will be included in the upcoming 2.9.2 release.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

McGregor
Posts: 11
Joined: Thu May 19, 2016 3:59 pm

Re: Search bug or feature

Post by McGregor » Wed Jul 27, 2016 7:20 am

It works!! thank you!

regards
Gregor

Post Reply