DEBUG INFORMATION:

Please report bugs here!

Moderator: Thorsten

Post Reply
member
Posts: 2
Joined: Sun May 25, 2008 8:23 am

DEBUG INFORMATION:

Post by member » Sun May 25, 2008 8:52 am

Hi all this is my first topic and i am sorry to be like this way to start with a bug

this is my first test of phpmyfaq

version is phpMyFAQ 2.5.0-alpha
installed on my localhost

my php version is 5.2.5
mysq version is 5.0.51a
apache version is 2.2.8
magic quotes gpc : on



safe mode : off
desplay error : on (i make it off and still the same bug)

Code: Select all

DEBUG INFORMATION:
PMF_Session->checkSessionId() in line 177:

            SELECT
                sid
            FROM
                faqsessions
            WHERE
                sid = 5
            AND
                ip = '127.0.0.1'
            AND
                time > 1211640394


PMF_Session->checkSessionId() in line 177:

                UPDATE
                    faqsessions
                SET
                    time = 1211726794,
                    user_id = -1
                WHERE
                    sid = 5
                    AND ip = '127.0.0.1'


PMF_Tags->existTagRelations() in line 322:

            SELECT
                COUNT(record_id) AS n
            FROM
                faqdata_tags


COOKIES:
pmf_sid: 5
ec8a6b59cc120f1a3d34d8103fab3c2f: b966200c9ac13250c777d1564f157b75
e899ea2516ca0f370b6a09362de766b0: 921a0a838605d2a54c98370626fe20d7
pageWidth: Fixed
style: null
fontSize: 76
webfxtab_content-pane: 0
eb5e862bb7e93b949039dafa0860635b: 694c756d9b4e7310aae8c5015d5bcde4
pmf_auth_: 000b9bs1ticd4dhbt3f6acb4d5
heartodark

matteo
Posts: 572
Joined: Sun Nov 20, 2005 6:53 pm
Location: Italy

Not a BUG ;)

Post by matteo » Sun May 25, 2008 9:05 am

Hi,
that box is not a bug :wink:: it is an hidden feature, usually enabled on alpha/beta versions, to allow the user to track any main PMF activity and help us to track a bug, if any.
Take a look at the inc/Init.php file:

Code: Select all

...
//
// Debug mode:
// - false      debug mode disabled
// - true       debug mode enabled
//
define('DEBUG', true);
...
Ciao,
Matteo
phpMyFAQ QA / Developer
Amazon.co.uk Wishlist

member
Posts: 2
Joined: Sun May 25, 2008 8:23 am

Post by member » Sun May 25, 2008 9:34 am

sorry it my mistake

and thanks


on the main page
under the login mod

he show this message

{msgLostPassword}
{msgRegisterUser}

they not linkable they just like i whrite it
if i click on login without entering the uername or pass shene he show me

User or password not valid.
Password forgotten? Click here.
{msgLostPassword}
{msgRegisterUser}

and the user online mod
the number of user grow with every page i change
and i install this script on my localhost no one can access to the site
heartodark

Post Reply