Partial data migration for new ver.PHPMyFAQ

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
Y.Takeuchi
Posts: 5
Joined: Wed Apr 24, 2024 12:29 pm

Partial data migration for new ver.PHPMyFAQ

Post by Y.Takeuchi »

Hello.

I have a problem with phpMyFAQ after upgrade.

I have done an incremental upgrade of phpMyFAQ, PHP and MySQL which is very unstable and has not solved the problem.

[Infrastructure.]
Azure Web App / nginx 1.24.0

[old configuration] *worked stably
 MySQL 5.7
 PHP 8.1
 phpMyFAQ 3.1.16

[New configuration]
 MySQL 8.0
 PHP 8.2
 phpMyFAQ 3.2.0

[Example problem]
- Failed to restore backup file with "404 Not Found" error -> Unable to log in to FAQ 
- "404 Not Found" error occurs when modifying FAQ.
- There may be other unconfirmed problems.

On the other hand, I have also confirmed that a clean install of phpMyFAQ with the new configuration works stably.

I would like to try to clear this problem by importing the backup data of the old configuration into a clean MySQL 8.0/PHP 8.2/phpMyFAQ 3.2.0 environment.
Is this possible? Also, are there any specific steps to follow?

I currently have the following resources
- MySQL 5.7 -> 8.0 dump file immediately after upgrade
- Backup of all phpmyFAQ 3.1.6 files (under faq/)
- Dump file immediately after upgrade to phpFyFAQ 3.2.0

At a minimum, I would like to import the following information into a clean environment
Appearance is not important.

- User account information
- FAQ categories
- FAQ posts (questions/answers/embedded images/attachments)

I hope someone can provide a good solution.
Thank you in advance.
Thorsten
Posts: 15570
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Partial data migration for new ver.PHPMyFAQ

Post by Thorsten »

Hi,

you should try 3.2.6 this way.

Create a database dump from the old installation, install a fresh installation on the new environment, import the database dump. Then run the update script. This should work.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
Y.Takeuchi
Posts: 5
Joined: Wed Apr 24, 2024 12:29 pm

Re: Partial data migration for new ver.PHPMyFAQ

Post by Y.Takeuchi »

Hello.
Thank you for your kind advice. And I apologize for the delay in my response.

I tried phpMyFAQ data migration according to the method you provided. Here's what I did:

1. I got the dump files for my old environment (MySQL 5.7/PHP 8.1/phpMyFAQ 3.1.16).
* phpMyFAQ is in maintenance mode

2. Installed phpMyFAQ3.2.6 in a new environment (MySQL8.0/PHP8.2)
-> /faq/setup/index.php

3. Put phpMyFAQ3.2.6 into maintenance mode and restored a DB backup of the old environment to the DB with the mysql command.

4. Run the update script in the WebUI of phpMyFAQ3.2.6.
-> /faq/setup/update.php

After this operation, the update screen shows the following and I cannot proceed.
”Please enable the maintenance mode in the admin section before running the update script.”

Also, I moved to the phpMyFAQ3.2.6 management screen, but I cannot operate the management screen with "404 not Found."

Please indicate if there is any difference between what I did and what you expected.

Thank you.

--
Yuko Takeuchi
Thorsten
Posts: 15570
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Partial data migration for new ver.PHPMyFAQ

Post by Thorsten »

Hi,

the 404 is strange as the URL is still the same for the admin backend with /admin/index.php

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
Y.Takeuchi
Posts: 5
Joined: Wed Apr 24, 2024 12:29 pm

Re: Partial data migration for new ver.PHPMyFAQ

Post by Y.Takeuchi »

Hello.

>the 404 is strange as the URL is still the same for the admin backend with /admin/index.php
I think the same as you.
Right now, the root page of the site also shows "404," so I can't find a solution.

Is it possible that the path to the faq is different between the old and new environments?
Example: old)/faq, new)/faq2

Also, are the operations I performed in 1. through 5 consistent with your assumptions?

I'll try a lot more for a while.
Thank you.
Thorsten
Posts: 15570
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Partial data migration for new ver.PHPMyFAQ

Post by Thorsten »

Hi,

did you update your .htaccess file?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
Y.Takeuchi
Posts: 5
Joined: Wed Apr 24, 2024 12:29 pm

Re: Partial data migration for new ver.PHPMyFAQ

Post by Y.Takeuchi »

Hello,

>did you update your .htaccess file?
No. I have not updated .htaccess.

I have confirmed that there is no problem with the following operation immediately after performing step 2 mentioned above, and decided that the update is unnecessary. If there is any error in my decision, please point it out.

- The front page of the site is displayed.
- The administrator account set during installation can be used to log in to the administration menu.
- The administrator menu can be switched to "Maintenance Mode."

After restoring a database dump, pages other than those under/config are no longer displayed.

Thank you.
Thorsten
Posts: 15570
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Partial data migration for new ver.PHPMyFAQ

Post by Thorsten »

Hi,

is your page public available so I can check the error?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
Y.Takeuchi
Posts: 5
Joined: Wed Apr 24, 2024 12:29 pm

Re: Partial data migration for new ver.PHPMyFAQ

Post by Y.Takeuchi »

Hello.

Unfortunately, my environment is in a closed network in the cloud, so now you can't check the status of the error. Thank you for your proposal.

I might be able to replicate the same symptoms in an open environment, so I would like to ask you then.

I'm guessing it's not a good idea, but is it acceptable for phpMyFAQ to work in the following configuration? It is a temporary operation until we get a good solution.

MySQL8.0/PHP8.2/phpMyFAQ3.1. x (16 or later)

Thank you.
Post Reply