Problems installing on IIS 6 and MS SQL 2008

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
Nuglor
Posts: 5
Joined: Wed Apr 04, 2012 5:31 pm

Problems installing on IIS 6 and MS SQL 2008

Post by Nuglor » Wed Apr 04, 2012 5:38 pm

I have tried to install 2.7.4 on a Windows Server 2003 IIS 6 and an Microsoft SQL 2008 DB as a background. Everything seems to be ok, at least the setup told me, but...

I cannot Login. The system is telling me all the time that the user or password was not found. When I try to register as a new user, the user will be created in the DB but I am not able to login anyway.

I have also problem with the captcha function which is telling me all the time that my entries are not correct.

Is it possible that there are any relationships between theses behaviors. Has anybody heard about something like this. I am really frustrated. We want to use the system for business purposes. It would be great if anyone has an idea to track this down....

Thanks a lot in advance.

Thorsten
Posts: 14728
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Problems installing on IIS 6 and MS SQL 2008

Post by Thorsten » Wed Apr 04, 2012 7:34 pm

Hi,

do you have entries in faquser, faquserdata and faquserlogin?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Nuglor
Posts: 5
Joined: Wed Apr 04, 2012 5:31 pm

Re: Problems installing on IIS 6 and MS SQL 2008

Post by Nuglor » Wed Apr 04, 2012 9:48 pm

Yes. One enty for Anonymous and One for the Admin User i have Chosen during the Installation. When i try to Register as a New User, the User is written to the dB but i am getting ab error.

Rgds. Matthias
Written on a mobile device. Please Excuse any typo.

Nuglor
Posts: 5
Joined: Wed Apr 04, 2012 5:31 pm

Re: Problems installing on IIS 6 and MS SQL 2008

Post by Nuglor » Thu Apr 05, 2012 11:02 am

Dear Thorsten!

I have installed a new system this time: Windows 2008, PHP 5.3 and SQL 2008 on IIS7 and I have exactly the same problem. Some aditional information. I deactivated captcha in the db in faqconfig and tried to register a new user. There is an error displayed says:

User account could not be created. in PMF_Auth local

Any ideas ?

Rdgs, frustrated Matthias ;)

Nuglor
Posts: 5
Joined: Wed Apr 04, 2012 5:31 pm

Re: Problems installing on IIS 6 and MS SQL 2008

Post by Nuglor » Thu Apr 05, 2012 12:51 pm

Next Update. I did tests the whole morning.

I installed an MySQL DB and System running fine, but I need to get it running on MSSQL 2008. I have played around with different DB Collations also. No changes.

I am using the extension:
extension= php_sqlsrv_53_nts_vc9.dll

Any experiences with it such an environment?

This sounds like the same problem:
viewtopic.php?f=7&t=12614&p=35670&hilit=sqlsrv#p35670

But there was no update on this. For me this sounds not like a supported and working feature :( Schade

Thorsten
Posts: 14728
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Problems installing on IIS 6 and MS SQL 2008

Post by Thorsten » Mon Apr 09, 2012 12:39 pm

Hi,

the ext/sqlsrv extension is still experimental, maybe we could work together to get it stable and perfectly working. Please check if your MS SQL database has the same data like the MySQL one.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Nuglor
Posts: 5
Joined: Wed Apr 04, 2012 5:31 pm

Re: Problems installing on IIS 6 and MS SQL 2008

Post by Nuglor » Mon Apr 09, 2012 2:04 pm

Hallo Thorsten!

Sehr gerne würde ich dass zum Laufen bekommen. Vllt. kurz zum Hintergrund. Ich möchte das System gern in unseren Support Bereich unserer Webseite integrieren. Ich hatte dazu bereits umfangreiche Tests mit MySQL bei meinem privaten Hoster gemacht, die erfolgreich verliefen. Daher fiel die Entscheidung auf Dein FAQ System, da in den Features der Einsatz auf MSSQL möglich war. Nun wollte unser Webmaster mit der Installation in unserer Serverlandschaft beginnen. Ziel ist der Einsatz auf IIS7 und MSSQL 2008. Die Erstinstallation soll noch auf IIS 6 laufen. Leider habe ich es zusammen mit dem Webmaster nicht hinbekommen und dann die weiteren Tests selbst in einer Virtuellen Maschine gemacht.

Ich werde die Datenbanken mal vergleichen. Auf welche Tabellen kommt es an? Nur die User Tabellen?

Viele Grüße

Matthias

Thorsten
Posts: 14728
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Problems installing on IIS 6 and MS SQL 2008

Post by Thorsten » Mon Apr 09, 2012 2:08 pm

Hi,

ich weiß von der alten ext/mssql Extension, dass das so funktioniert. Die wichtigen Tabellen sind die faquser, faquserdata und faquserlogin sowie faqright und faquser_right

Leider bin ich auf Windows Administration sehr unfit, deswegen konnte ich hier nie eine Testumgebung aufbauen...

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Thorsten
Posts: 14728
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Problems installing on IIS 6 and MS SQL 2008

Post by Thorsten » Mon Nov 26, 2012 7:43 pm

Hi,

already fixed some months ago.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

jimmy
Posts: 1
Joined: Sat Jan 19, 2013 8:19 am

Re: Problems installing on IIS 6 and MS SQL 2008

Post by jimmy » Sat Jan 19, 2013 8:21 am

I don't believe that needs scripts to be loaded in the header.
Jimmy Steven

Post Reply