Upgrade 3.0.1 auf 3.1.1 - Sorry, but you need PHP 7.4.0 or later

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
scape
Posts: 189
Joined: Tue Apr 08, 2003 1:16 pm

Upgrade 3.0.1 auf 3.1.1 - Sorry, but you need PHP 7.4.0 or later

Post by scape »

Hallo. Beim Versuch das Update-Script aufzurufen erhalte ich die Fehler-Meldung
Sorry, but you need PHP 7.4.0 or later!
Das war zum Zeitpunkt des Erstaufruf des Scripts zwar korrekt, da ich noch auf 7.3 war aber auch der Wechsel auf 7.4 und jetzt sogar 8.0 bringt keine Hilfe.
scape
Posts: 189
Joined: Tue Apr 08, 2003 1:16 pm

Re: Upgrade 3.0.1 auf 3.1.1 - Sorry, but you need PHP 7.4.0 or later

Post by scape »

Sorry, ich Trottel hatte vergessen, dass der Webserver die PHP-Version für Subdomains separat handhabt und die Installation der FAQ auf einer Sub läuft. Sorry erstmal!
scape
Posts: 189
Joined: Tue Apr 08, 2003 1:16 pm

Re: Upgrade 3.0.1 auf 3.1.1 - Sorry, but you need PHP 7.4.0 or later

Post by scape »

Okay… jetzt lande ich beim Aufruf der https://faq.die-formel.de/setup/update.php
in einer Endlosschleife :shock:

Code: Select all

https://faq.die-formel.de/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/setup/index.php
scape
Posts: 189
Joined: Tue Apr 08, 2003 1:16 pm

Re: Upgrade 3.0.1 auf 3.1.1 - Sorry, but you need PHP 7.4.0 or later

Post by scape »

… was ich jetzt durch das Zurückspielen der "database.php" in den "config" Ordner verhindern konnte.
Ob das gut und richtig war wird sich jetzt zeigen…
scape
Posts: 189
Joined: Tue Apr 08, 2003 1:16 pm

Re: Upgrade 3.0.1 auf 3.1.1 - Sorry, but you need PHP 7.4.0 or later

Post by scape »

… jetzt musste ich noch den Wartungsmodus manuell in der Datenbank auf "true" umstellen

Code: Select all

faqconfig > main.maintenanceMode
um von Schritt 1 des Update-Prozesses weiterzukommen aber nun läuft alles einwandfrei.

Und nun habe ich auch meinen Fehler gefunden, der aber auch ein Stück weit am Wording der Update-Beschreibung liegt…
3.2. Upgrading from phpMyFAQ 3.0.x
Upgrading from 3.0.x is a major upgrade. Please make a full backup before you run the upgrade! First you have to delete all files except:
  • database.php and ldap.php (if you use LDAP) in the directory config/
  • all files in the directory assets/template/
  • the directory attachments/
  • the directory data/
  • the directory images/
Als DAU bin ich hier davon ausgegangen, dass sich der LDAP-Hinweis auf beide Files bezieht.
Wirklich Idiotensicher wäre hier meiner Ansicht nach folgende Beschreibung…
  • in the directory config/
    • keep the file database.php
    • only if using LDAP also keep the file ldap.php
  • in the directory assets/template/
    • keep all files
  • the directory attachments/
  • the directory data/
  • the directory images/
Thorsten
Posts: 15373
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Upgrade 3.0.1 auf 3.1.1 - Sorry, but you need PHP 7.4.0 or later

Post by Thorsten »

Hi,

guter Punkt, ich passe das Wording an!

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
scape
Posts: 189
Joined: Tue Apr 08, 2003 1:16 pm

Re: Upgrade 3.0.1 auf 3.1.1 - Sorry, but you need PHP 7.4.0 or later

Post by scape »

Danke, Thorsten! Letzte Frage zum Update: War es nicht mal so, dass man den Setup-Ordner am Ende der Installation löschen sollte?
Post Reply