Neuinstallation von phpmyfaq 2.5.4

Please report bugs here!

Moderator: Thorsten

Fr33z3m4n
Posts: 42
Joined: Fri Nov 06, 2009 10:36 am

Neuinstallation von phpmyfaq 2.5.4

Post by Fr33z3m4n » Thu Nov 12, 2009 9:25 am

Neuinstallation !
Mysql, LDAP ausgefüllt.
Fehlermeldung:

Code: Select all

Warning: Invalid argument supplied for foreach() in D:\Projekte\PHP\phpmyfaq\inc\Ldap.php on line 95
All database tables were successfully created.

Congratulation! Everything seems to be okay.

Thorsten
Posts: 15165
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Neuinstallation von phpmyfaq 2.5.4

Post by Thorsten » Thu Nov 12, 2009 9:33 am

Hi,

ah... ist aber kein Problem, beim normalen LDAP Verbindungsaufbau sollte es klappen. Da werden im Installskript nur nicht die LDAP Options eingebunden. Ich fixe das.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Cyberplanet
Posts: 18
Joined: Tue Nov 17, 2009 11:16 am

Re: Neuinstallation von phpmyfaq 2.5.4

Post by Cyberplanet » Tue Nov 17, 2009 11:34 am

ok ich bekomme aber auch beim erstellen des FAQ kein Bild dargestellt. kann das daran liegen.

und wie baue ich beim anmelden eine l-dap verbindung bzw wie konfiguriere ich das weil der fehler kommt schon beim öffnen der Seite

Thorsten
Posts: 15165
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Neuinstallation von phpmyfaq 2.5.4

Post by Thorsten » Tue Nov 17, 2009 11:38 am

Hi,

hast du LDAP in der Konfiguration aktiviert?

Welche Fehlermeldungen erhälst du beim Einfügen von Bildern?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Cyberplanet
Posts: 18
Joined: Tue Nov 17, 2009 11:16 am

Re: Neuinstallation von phpmyfaq 2.5.4

Post by Cyberplanet » Tue Nov 17, 2009 2:40 pm

Nicht von Bildern sondern wenn ich eine neue FAQ erstellen möchte hat man ja unten den Punkt

Bitte die Zeichen der Captcha-Grafik eingeben

Da ist bei mir nur ein Großes X


Wie kann ich das mit dem LDAP Problem lösen bzw den Fehler entfernen.

Thorsten
Posts: 15165
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Neuinstallation von phpmyfaq 2.5.4

Post by Thorsten » Tue Nov 17, 2009 2:46 pm

Hi,

dann ist dein GD nicht aktiviert oder kaputt.

Zum Thema LDAP: Du musst das halt korrekt konfigurieren...

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Cyberplanet
Posts: 18
Joined: Tue Nov 17, 2009 11:16 am

Re: Neuinstallation von phpmyfaq 2.5.4

Post by Cyberplanet » Tue Nov 17, 2009 2:51 pm

Frag ja ungern so doof :-) aber wo im admin interface finde ich nichts dazu

den hacken habe ich gesetzt

Thorsten
Posts: 15165
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Neuinstallation von phpmyfaq 2.5.4

Post by Thorsten » Tue Nov 17, 2009 3:04 pm

Hi,

die LDAP Optionen sind ja je nach Serverkonfiguration und Environment anders. Das musst du in der inc/constants_ldap.php händisch anpassen.

Die inc/dataldap.php ist bei dir vorhanden?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Cyberplanet
Posts: 18
Joined: Tue Nov 17, 2009 11:16 am

Re: Neuinstallation von phpmyfaq 2.5.4

Post by Cyberplanet » Tue Nov 17, 2009 3:08 pm

leider nein.

ich habe nur eine ldap.php

Thorsten
Posts: 15165
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Neuinstallation von phpmyfaq 2.5.4

Post by Thorsten » Tue Nov 17, 2009 3:21 pm

Hi,

öh... du benötigst eine Datei mit dem Namen "dataldap.php" im Ordner inc/

Die muss so aussehen:

Code: Select all

<?php
$PMF_LDAP["ldap_server"]     = 'LDAP Server';
$PMF_LDAP["ldap_port"]        = 'LDAP Port';
$PMF_LDAP["ldap_user"]        = 'LDAP User';
$PMF_LDAP["ldap_password"] = 'LDAP Passwort';
$PMF_LDAP["ldap_base"]        = 'LDAP BASE ';
bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Cyberplanet
Posts: 18
Joined: Tue Nov 17, 2009 11:16 am

Re: Neuinstallation von phpmyfaq 2.5.4

Post by Cyberplanet » Tue Nov 17, 2009 3:24 pm

ich werde die nun mal selber erstellen.

ist das die komplette datei oder war das nur ein auszug.

Thorsten
Posts: 15165
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Neuinstallation von phpmyfaq 2.5.4

Post by Thorsten » Tue Nov 17, 2009 3:25 pm

Hi,

das ist die komplette Datei. Die hätte eigentlich beim Installieren erstellt werden müssen...

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Cyberplanet
Posts: 18
Joined: Tue Nov 17, 2009 11:16 am

Re: Neuinstallation von phpmyfaq 2.5.4

Post by Cyberplanet » Tue Nov 17, 2009 3:35 pm

<?php
$PMF_LDAP["ldap_server"] = 'ldap.xxserver10.local;
$PMF_LDAP["ldap_port"] = '389';
$PMF_LDAP["ldap_user"] = 'administrator';
$PMF_LDAP["ldap_password"] = xxxxxxx';
$PMF_LDAP["ldap_base"] = 'dc=domainname,dc=local';


so habe ich es und der fehler ist leider immer noch vorhanden.

wenn ich den ldap support abschalte wieso ist der fehler dann eigentlich noch vorhanden

Thorsten
Posts: 15165
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Neuinstallation von phpmyfaq 2.5.4

Post by Thorsten » Tue Nov 17, 2009 3:36 pm

Hi,

welchen Fehler meinst du denn?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Cyberplanet
Posts: 18
Joined: Tue Nov 17, 2009 11:16 am

Re: Neuinstallation von phpmyfaq 2.5.4

Post by Cyberplanet » Tue Nov 17, 2009 3:43 pm

ja den

phpMyFAQ warning [2]: mssql_select_db() [function.mssql-select-db]: message: In 'sysdatabases' wurde kein Eintrag für die 'DB_MAYFAQ'-Datenbank gefunden. Es wurde kein Eintrag mit diesem Namen gefunden. Stellen Sie sicher, dass der Name richtig eingegeben wurde. (severity 16) in Mssql.php on line 71

phpMyFAQ warning [2]: mssql_select_db() [function.mssql-select-db]: Unable to select database: DB_MAYFAQ in Mssql.php on line 71

der steht ganz groß oben im Forum das nervt ganz schön und jeder der sich drauf schaltet beschwert sich dann immer.

Irgendwie muss das ja weg gehen


edit: sorry seh das ich gerade im ganz falschen beitrag schreibe.

Post Reply