Problem mit E-Mail und PDF Link unter einem Beitrag

Please report bugs here!

Moderator: Thorsten

Post Reply
RWarnecke
Posts: 68
Joined: Sat Oct 10, 2009 5:57 pm
Location: Stuttgart
Contact:

Problem mit E-Mail und PDF Link unter einem Beitrag

Post by RWarnecke »

Hallo,

ich habe zuerst auf die Version 2.7.0 upgedated. Da ist mir das Problem noch nicht aufgefallen. Erst beim Update auf die Version 2.7.3. Und zwar werden für diese beiden Zeilen kein Link in der Datei index.php geschrieben :

Code: Select all

'link_email'             => $faqServices->getSuggestLink(),
'link_pdf'               => $faqServices->getPdfLink(),
Im Quelltext der Seite taucht dann nur folgendes auf :

Code: Select all

<a href="{link_email}"><img src="images/email.gif" alt="{writeSend2FriendMsgTag}" title="{writeSend2FriendMsgTag}" width="16" height="16" border="0" class="recordIcons" /></a> 
<a target="_blank" href="{link_pdf}"><img src="images/pdf.gif" alt="{writePDFTag}" title="{writePDFTag}" width="16" height="16" border="0" class="recordIcons" /></a>
Damit stehen die beiden Funktionen nicht zur Verfügung. Kann mir da jemand weiterhelfen ?
Gruß

Rolf Warnecke
Thorsten
Posts: 15392
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Problem mit E-Mail und PDF Link unter einem Beitrag

Post by Thorsten »

Hi,

ah, ich sehe, du nutzt ein 2.6er basierendes Template mit der 2.7. Ich schau mal, wie ich das fixen kann.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
Thorsten
Posts: 15392
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Problem mit E-Mail und PDF Link unter einem Beitrag

Post by Thorsten »

Hi,

füge einfach

Code: Select all

            'link_email'             => $faqServices->getSuggestLink(),
            'link_pdf'               => $faqServices->getPdfLink(),
in die artikel.php unten ein, das sollte klappen.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
RWarnecke
Posts: 68
Joined: Sat Oct 10, 2009 5:57 pm
Location: Stuttgart
Contact:

Re: Problem mit E-Mail und PDF Link unter einem Beitrag

Post by RWarnecke »

Thorsten wrote:ah, ich sehe, du nutzt ein 2.6er basierendes Template mit der 2.7. Ich schau mal, wie ich das fixen kann.
Du hattest in Deiner Dokumentation geschrieben bei einem Update von 2.6 auf 2.7, dass das Template-Verzeichnis ausgelassen werden sollte.

Ich habe die beiden zeilen in die artikel.php eingefügt und es funktioniert hervorragend.

Diese drei Zeilen müssen auch noch rein :

Code: Select all

            'writePDFTag'            => $PMF_LANG['msgPDF'],
            'writePrintMsgTag'       => $PMF_LANG['msgPrintArticle'],
            'writeSend2FriendMsgTag' => $PMF_LANG['msgSend2Friend'],
Gruß

Rolf Warnecke
Thorsten
Posts: 15392
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Problem mit E-Mail und PDF Link unter einem Beitrag

Post by Thorsten »

Hi,

ja, da steht aber auch:
You have to update a lot of your template files due to our markup change from XHTML 1.0 to HTML5.
bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist
RWarnecke
Posts: 68
Joined: Sat Oct 10, 2009 5:57 pm
Location: Stuttgart
Contact:

Re: Problem mit E-Mail und PDF Link unter einem Beitrag

Post by RWarnecke »

Oh mist, wieder die Anleitung nur bis zur Hälfte gelesen. :oops:
Gruß

Rolf Warnecke
Post Reply