Falsche Suchergebnisse nach Serverumzug

All about webserver configurations, PHP and databases.

Moderator: Thorsten

Post Reply
maresystem
Posts: 3
Joined: Mon Oct 25, 2010 8:27 am

Falsche Suchergebnisse nach Serverumzug

Post by maresystem » Mon Oct 25, 2010 8:44 am

Moin,

ich habe eine ältere phpmyfaq-installation (2.0.9) von einem alten Suse-Server auf ein aktuelles debian
migriert; db/php/config 1zu1 übertragen, das ganze hat auch wunderbar funktioniert.

einziges problem: die suche funktioniert nicht mehr so, wie vorher:
wenn ich nach "suche diesen text" eingebe erscheint in der url
/faq/index.php?search=suche+diesen+text ... und die suche liefert
hunderte ergebnisse; wenn ich aber "suche +diesen +text" eingebe
ist die url folgendermaßen: /faq/index.php?search=suche+%2Bdiesen+%2Btext
und die suche liefert die gewünschten ergebnisse.

habt ihr irgend eine idee, woran das liegen kann?


mit besten grüßen,


markus

Thorsten
Posts: 14720
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Falsche Suchergebnisse nach Serverumzug

Post by Thorsten » Tue Oct 26, 2010 8:17 pm

Hi,

ist das immer noch eine 2.0.9 oder auf 2.6.9 aktualisiert? Welches PHP, welches MySQL läuft da?

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

maresystem
Posts: 3
Joined: Mon Oct 25, 2010 8:27 am

Re: Falsche Suchergebnisse nach Serverumzug

Post by maresystem » Thu Oct 28, 2010 10:54 am

moin thorsten,

folgende versionen sind installiert:

mysql: 5.0.51a
php: 5.2.6

phpmyfaq: 2.0.9 ich habe die version einfach rübergezogen (altsystem war ein suse 10.x),
das war soweit auch in ordnung; nur, wie gesagt, die suche verhält sich irgendwie anders.



vielen dank!

Thorsten
Posts: 14720
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Falsche Suchergebnisse nach Serverumzug

Post by Thorsten » Sun Oct 31, 2010 8:54 am

Hi,

hat sich die MySQL-Version geändert? Von 4 auf 5? Dann liegt das daran.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

maresystem
Posts: 3
Joined: Mon Oct 25, 2010 8:27 am

Re: Falsche Suchergebnisse nach Serverumzug

Post by maresystem » Wed Nov 03, 2010 2:06 pm

gibts ne möglichkeit, das verhalten wieder so zu ändern, wie
das vorher war?

Thorsten
Posts: 14720
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Falsche Suchergebnisse nach Serverumzug

Post by Thorsten » Wed Nov 03, 2010 7:27 pm

Hi,

in der 2.0.9 wohl nur durch üble Hacks. Du solltest wirklich auf eine aktuelle Version upgraden, die 2.0.9 hat einige fiese Lücken.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply