Theme broke after update to 2.9

You made an own skin or theme for phpMyFAQ. You can share it here with others!

Moderator: Thorsten

Post Reply
lnm_bert
Posts: 1
Joined: Tue Mar 27, 2018 4:57 pm

Theme broke after update to 2.9

Post by lnm_bert » Tue Mar 27, 2018 5:08 pm

Hi,

I recently upgraded from 2.8 to 2.9.10. Most of the FAQ seems to still work as before, except for the styling.
I read that the templates from previous versions are "barely compatible", but I did not originally build the theme so I'm not sure how to fix it.
3.5. Modifying templates for phpMyFAQ 2.9.x

Your current 2.6.x, 2.7.x and 2.8.x templates are barely compatible with phpMyFAQ 2.9 because we changed the complete CSS framework to Bootstrap v3. We're also using a lot of Ajax based technologies and CSS3 in the frontend now. We moved the login from a dropdown form to an own page with the login form. We also added a glossary page which you might know from the administration backend from older versions.

We recommend you'll take a look at the main Bootstrap documentation. Please don't forget that the style sheets are written with LESS. You have to compile the LESS files into CSS using a LESS compiler with Node.js or a tool like CodeKit.

If you need help with theming phpMyFAQ please don't hesitate to ask in our forum or visit our new theme page. We will also release new themes from time to time on our homepage and release them as open source on our Github page.

Note: The character set for all languages and templates is UTF-8. If you notice problems with e.g. German umlauts you have to convert your templates to UTF-8 encoding. Please use UNIX file endings \n instead of Windows file endings with \r\n.
As this is just for internal use, I was wondering if there is a default theme for 2.9 that can be used? I cannot see how to change a theme from the admin panel, nor do I know where I could find a basic or default theme that is compatible with 2.9?

Thanks for any help!

Update: it works now. Seems like it was a weird CSS caching issue? Leaving this up in case someone else encounters this.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests