Failed to upgrade from 2.9.13 to 3.0.0 with Postgresql 9.1 and PHP 7.3

Please report bugs here!

Moderator: Thorsten

Post Reply
gbri
Posts: 3
Joined: Mon Sep 09, 2013 9:19 am

Failed to upgrade from 2.9.13 to 3.0.0 with Postgresql 9.1 and PHP 7.3

Post by gbri » Thu Feb 27, 2020 3:58 pm

Failed to upgrade from 2.9.13 to 3.0.0 with Postgresql 9.1 and PHP 7.3

Few points :
1/ $DB['port'] was not required on database.php previous version, maybe it would be better to add a note on Upgrading documentation to inform users to add this parameter on database.php file
2/ On setup/update.php (lines 572,608,623 to 631,663) few ALTER TABLE and CREATE TABLE with INT(11) or INT(1) which are not compliant with Postgresql, should be replace by INTEGER or SMALLINT
3/On setup/update.php line 648 $perm->renameRight('delete_user', 'delete_user'); should be replace by $perm->renameRight('deluser', 'delete_user');

Cheers,

Ben

Thorsten
Posts: 15051
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Failed to upgrade from 2.9.13 to 3.0.0 with Postgresql 9.1 and PHP 7.3

Post by Thorsten » Thu Feb 27, 2020 6:57 pm

Hi,

thanks a lot for your bug report.
1/ $DB['port'] was not required on database.php previous version, maybe it would be better to add a note on Upgrading documentation to inform users to add this parameter on database.php file
The database port is just optional, where did you ran into an issue?
2/ On setup/update.php (lines 572,608,623 to 631,663) few ALTER TABLE and CREATE TABLE with INT(11) or INT(1) which are not compliant with Postgresql, should be replace by INTEGER or SMALLINT
thanks, fixed for 3.0.1
3/On setup/update.php line 648 $perm->renameRight('delete_user', 'delete_user'); should be replace by $perm->renameRight('deluser', 'delete_user');
also fixed for 3.0.1

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

gbri
Posts: 3
Joined: Mon Sep 09, 2013 9:19 am

Re: Failed to upgrade from 2.9.13 to 3.0.0 with Postgresql 9.1 and PHP 7.3

Post by gbri » Fri Feb 28, 2020 1:53 pm

Hi,

Not sure if the upgrade failed due to the missing 'port' in database.php or only due to wrong sql for Postgres in update.php.
I will check with version 3.0.1

Thanks for your great job !

Ben

Thorsten
Posts: 15051
Joined: Tue Sep 25, 2001 11:14 am
Location: #phpmyfaq
Contact:

Re: Failed to upgrade from 2.9.13 to 3.0.0 with Postgresql 9.1 and PHP 7.3

Post by Thorsten » Sat Feb 29, 2020 7:48 am

Hi,

I'm creating an additional PostgreSQL development environment for checking these issues for the 3.0.1 release.

bye
Thorsten
phpMyFAQ Maintainer and Lead Developer
amazon.de Wishlist

Post Reply